Resolved
SSO provider applied the fix and everything is back to normal.
Monitoring
The root cause was identified of the issue and the SSO provider implemented a fix. Error rates are improving.
Identified
SSO is not working on the platform. The third party we are using to manage SSO is unavailable at the moment. If you have a valid session it will keep working as usual.